
Ecco MagicMerge  

  

  Direct Merge for MS Word 
(with Direct E-Mail)  

Introduction to Tool:  

The idea of tool is to provide a '1-step' 
instant merge feature for Ecco via Word.  

There is no need to select folders to 
'output'.   (The  folder  selection  comes  into 
play only when you create new Word 
templates and  use  the  Template  Building 
Tool.)  

There is no need to 'export' anything.  

There is no need to open Word, or to 
manually point Word to anywhere.  

You can instantly create a template merge 
file 'on the fly' from any ordinary ".doc" 
file-- just insert the folders you want 
wherever you desire in the document. You 
can freely control merge formatting 
through normal Word merge formatting 
options, and include date folders as actual 
dates (ie., instead of ecco date codes). 

You can even use existing 'correspondence 
manager' templates, and freely copy and 
modify existing templates without any 
special procedures or tools.  

You  simply  open  any  Ecco  file,    either 
manually  select  items,  or use  any 
selection filter or query in the phone 
book, and then "Merge!" (or print, or 
email) with *any* Word document or 
Dot file.  

   

Activating Word Merge:  

Any of the following will activate 
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Any of the following will activate 
MagicMerge:  

1) Left click on the MagicMerge 
tray icon.  

2) Right click on the tray icon 
and select 'Word Merge!'.  

3) Press the Windows Key + 
Shift + W from within Ecco.  

Note: If a Ecco is active with a 
Word document as the current item, 
that document will be automatically 
opened in Word for merging.  
 
You can thus keep a 'library' of 
forms in your Ecco file, and merge 
as easy as 1-2-3. If the phonebook is 
filtered with the items you want to 
merge, simply: 1) select the desired 
form in Ecco, 2) activate 
MagicMerge and 3) click "Merge". 
 
Note: You do not have to open Word 
documents to merge them. Only 
documents saved inside an Ecco file 
need to be opened in order to merge 
them (because they have no 
independent address in the windows 
file system). 

Pressing the "Shift" key when 
executing a merge (eg, by 
clicking on the "MERGE" 
button), allows multiple merges 
from the same MagicMerge 
dialog. 

 
Activating Word Merge for 
Email:  

To activate Word merge for EMAIL: 

1) press Windows Key + Shift + 
W + E, or,  
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W + E, or,  

2) hold down the 'Shift' key while 
clicking on the MagicMerge tray 
icon, or when selecting 'Word 
Merge!' from the  tray icon menu. 

Note: The "Advanced E-Mail Options" 
on the MagicMerge tray icon 
menu allows for  selection of advanced 
email options such as HTML text 
formatting,   attaching  the  merged 
output as a .Doc attachment to the 
email, or the use of email plain text. 
(Older versions of Word do not 
support HTML formatting.)   

Using the Advanced E-Mail Options 
you  can  also  modify  the   'Recipient 
Options' to have recipients selected 
either from the first folder 
containing the word   "E-Mail" used in 
the  Word  template  file,   or  from  a 
folder manually entered.  Because you 
can use 'hidden' folders in the Word 
template,   it  is  recommended  to  use 
this option.  For example, at the start of 
your template include:  

TO:  {Outgoing_E_Mail}    
[Part of your template -- not 
hidden] 
 
            -or- 
 
{ IF 1 = 2 
"{Outgoing_E_Mail  }"}    
[Hidden] 

You can use the MagicMerge template 
building tool to automatically insert 
the field (in the correct form) for the 
folder you desire.  

If the "Subject" line is left blank in the 
MagicMerge  activation  dialog,   the 
Subject of the Document is used as the 
subject line for the outgoing email. 
 You  can  also  edit  the  subject  field in 
Word (via File > Properties > 
Summary > Subject: ).   This way each 
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Summary > Subject: ).   This way each 
Word Template can have it's own 
default  Subject  for  emailing,   which 
you can always override simply by 
manually entering a subject in the 
activation dialog. 

Note that E-Mail, Fax, and direct 
Printing is not available in MS Word 
for   "Report"  type  merges.   (See  
"Document Type Control", below ). 
Since reports use multiple records to 
print  a  single  document,   there  is  no 
way MS Word can determine which 
record was intended to hold the "To:" 
information, etc.  

 
Activating Word Merge direct 
Printing:  

To directly print a merge (without 
creating a merged Word output file), 
hold down the 'Control' key when 
selecting  'Word Merge!'  from  the   tray 
icon menu. 

 
Activating Word Merge Faxing:  

Note: This feature is not 'officially' a part of 
MagicMerge because the internal support 
for faxing is so varied across different 
systems.  It is included as a 'bonus' feature.   
If  it  works  for  you,   enjoy!     If  it  doesn't, 
 and you need support  to  get  it  to work on 
your particular system or set-up,   we  can 
help, but you'll have to pay hourly for us to 
figure out your system & structure the tool 
to  fit.     If  you have Word versions prior  to 
2002 or 2003 (or in some cases prior to 
2007),   the  fax  feature  will  likely  not  be 
available to you.   Depending on your set-up 
(eg., Home, Vista, Premium, etc.)  you may 
be able to fax but not auto-select the fax to 
phone number.  Some 3rd party  fax drivers 
may also cause  this  feature  to  fail.  A wide 
variety of system security settings can also 
interfere with the faxing feature.   
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interfere with the faxing feature.   

To directly fax a merge, hold down the 
'Shift' and 'Windows" keys when 
selecting 'Word Merge!' from the tray 
icon  menu,   or  when  left  clicking  on 
the tray icon. 

The same rules that apply to E-Mail 
merging also apply to fax merging. To 
designate which folder contains the 
"To:" phone number, in place of "E-
Mail", substitute "Fax". The E-Mail 
option settings apply to fax sending. 

The fax merge field should be formatted in any one 
of the following ways:           
           

   9, (XXX) ###-####           
   9, XXX-###-####           
   9, XXX#######           
    [FAX:9,XXX-###-####]                  
           

           
In these examples, "9," is used at the beginning of the 
number (in some offices you must dial 9 first and 
wait for a dial tone in order to access an outside line). 
The "9" can be omitted if you do not need to dial 9 to 
access an outside line. "XXX" is optional if the fax 
numbers are local and do not require an area code. 

 
Selection of Ecco items to merge 

A wide variety of source items can be 
merged: 

Currently SELECTED Ecco 
Items  

Will merge the data from the 
current selection. Items can be 
selected in Ecco manually (click 
and  control+click;   Shift  + 
Pagedown,  Shift + control + end, 
etc. 

Items (and folder contents) can 
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Items (and folder contents) can 
also be mass  selected in Ecco via 
a search by selecting the "All in 
view" option. 

Filtered Ecco PHONEBOOK 

Will merge the data from 
whatever phonebook items are 
currently displayed in the 
phonebook view. (Even if the 
phonebook is not currently 
displayed). 

The phonebook search, advanced 
search and "Query",   as well  as a 
filter and 'Alt + A' (display all) 
allow for easy listing of items in 
the phonebook. 

Active Ecco notepad TLIs 

Will merge the data from the top 
level items (TLIs) of the currently 
active notepad (including the 
calendar).   

In multi-view notepad views, the 
base notepad provides the data 
(not 'added in' additional views). 

If any filters are active in the 
notepad,  they will also be applied 
to the merge data. 

Active Ecco notepad (Folder 
Items) 

Will merge the data from the 
items in the currently active 
notepad that belong to the 
notepad because of their folder 
setting.  (ie.   not  'context  parents' 
or children of items, unless the 
parent or child is also assigned to 
the relevant folder). 

Whereas the 'Active Ecco 
notepad (TLIs)' dataset will use 
the data from top level items even 
if they are not assigned to any 
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if they are not assigned to any 
folder displayed in the notepad, 
'Active Ecco notepad (Items)' will 
use data from any item (child or 
TLI), so long as the item directly 
belongs to the notepad (ie. not a 
context parent or child of a 
belonging item). Child items are 
included if they are independently 
associated with any of the folders 
in the notepad. 

Active Ecco notepad (Every 
Item) 

Will merge the data from the 
items shown in the currently 
active notepad. (ie. includes 
'context parents' and children 
regardless of any folder 
assignments). 

 
Selection of a Word Template 
file:  

There are several ways to select which 
Word file to merge. You can:  

1) Drag & Drop the file from 
windows explorer onto the file 
selection box.  

2)  Type  in  "Browse.."   or  select 
"Browse.." from the bottom of 
the pull-down selection list.  

3) Paste the file name into the 
selection box.  

   

You can also select (from the 
pulldown  box),   previously  merged 
files,  or,   the  currently  Active  Word 
Document.  

Use of the "Active Word Document" 
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Use of the "Active Word Document" 
option allows you to save Word templates 
directly  in your Ecco  file,   double click  to 
select  (and  open)  that  template,   and  then 
merge.   (This  allow keeping  the  Template 
and data in a single .eco file). Typing "A" 
and down arrow in the file selection box 
will instantly bring up the first matching 
item starting with the letter "A", and 
typically will be a shortcut to the 'Active 
Word Document' option. 

 
Document Type Control  

By right clicking on the MagicMerge 
tray icon and selecting "Document 
Type" you can override the type of the 
merged document.  
 
This control relates to how the merged 
document will be created-- one 
document per data set (such as letters), 
a linear report of data (such as a multi-
line report in a single document), etc.  

Typically in Word, the type of 
document is set when using the Tools 
> MailMerge Tools > (Document) 
Create feature. With MagicMerge you 
can merge to the format originally set 
for such a Template, or you can 
override and manually select a 
different merge type. 

The default MagicMerge setting is to 
use the existing type of the Word file 
of the merging template.  

Note: You can use any Word document 
or  .dot  as  a MagicMerge  template,   even  if 
the document is a standard, plain old Word 
document-- ie. there is no need to use the 
Tools-MailMerge-Create feature of Word. 

To  override   the Word  'created' merge 
type  for 'created' merge  files,  or to  set 
a default merge type in 'plain jane' 
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a default merge type in 'plain jane' 
Word files,  you can use the "EMType" 
file property.  To do so: 

1. Create a file property called 
"EMType".   (Typically in Word 
via File > Properties > Custom).  

2. Enter in the  "EMType"  
property the desired type:  

 
"Letter"  for Form 
Letters    
 
"Report"  for multi-line 
reports   
 
"Envelopes"   
 
"Labels" 

 

Date Style Control  

By default dates merge in "Short" date 
format. 
 
From the MagicMerge tray icon 
"Options > Date Styles" menu you can 
select "Long" dates, or, the "Raw" 
Ecco date format  

 
Date Format Options  

From  the  Date  Format  Control menu 
("Options  > Date  Formats"),   you  can 
select the default format for dates:   

Full (Dates and Times) (This 
option is ignored when raw ecco 
date format is used) ;  

Dates only ;  
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Times only ;   

Only the starting date and time ;   

Only the starting date ;  and  

Only the starting time.   

 
Setting Style/Format in Word   

Date style and formatting will be 
overridden if explicitly set in any Word 
template. 
 
To set date style and formatting for any 
template:  

1. Create a file property called 
"EMDate".     (Typically  in  Word 
via File > Properties > Custom).  

2.  Enter  in  the   "EMDate"  date 
property the desired style:  

"Short"  for short dates  

"Long"  for long dates  

3. Add any special formatting:  

"/S"      for  Starting  Date  & 
Time  

"/SD" for Starting Date  

"/ST" for Starting Time  

 
Note: This works very similar to setting 
default  Email  Subjects  using  the  file's  
"Subject" property. 
 
But note,    

1) "EMDate" will always be added 
(and edited) from the "Custom" 
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(and edited) from the "Custom" 
Properties dialog in Word while 
"Subject" is typically found in the 
Word File properties "Summary", and   

2) Manual selection of a subject during 
an Email Merge will override the 
Word file's 'Subject' property, but the 
Word file's 'EMDate' property will 
override manual selection of date style 
and format.  

 

Header Record 

The "Header Record" option allows 
using the first currently displayed 
phonebook item as record "1" within 
the merge. 

Thus,  for  example,   the  address  and 
salutation data can be merged from the 
phonebook item and the 'report items' 
merged from elsewhere in Ecco.  
 
Ie. the main data can be merged, for 
example, from a filtered notebook view, 
while the phonebook view contains the 
addressee for the letter/report. The data will 
be merged, as if the phonebook item was the 
first item in the filtered notebook view. (For 
more information on how to take advantage 
of this type of merge see the 'Advanced 
Ecco/Word usage Note' below). 

Font Codepage 

For those who have non-English (or 
special English/Graphics) in either 
Ecco items or folders.   

Via  the tray  icon  right  click  "Options" 
menu, select "Font CodePage":  

Default CodePage uses whatever 
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Default CodePage uses whatever 
default codepage is currently 
configured for windows at the 
time the merge is run. 

Change CodePage allows 
selecting whatever alternative 
codepage desired. You can 
instantly change back and forth 
between using the default 
codepage, or the selected 
alternative.  

If unsure about which codepage to use, 
look at Window's control panel 
'Regional and Langauge Opions", 
 "Advanced"  tab,  for  a  full  list  of 
codepages supported by that windows 
setup. 

Merge Tracking 

The "Merge Tracking" option allows 
automatic recording each merge, e-
mail,  fax,  or  print  run   in  your  Ecco 
file. 

Because this modifies (adds data to) 
your .eco file,  this option will only be 
enabled if you do two things: 

1. Enable the option in 
MagicMerge. 

2. Include in the file a folder 
named "MagicMerge Tracking". 

A MagicMerge Tracking 
folder must exist in each 
file you want to activate 
Merge  Tracking  for.   This 
is required to insure that 
you never accidentally 
modify a file's data with 
MagicMerge.  
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MagicMerge.  

With this option enabled, each merge 
will add a folder with the date and time 
of the merge to each item included in 
the merge. By viewing an item's 
attached folders you can see a 
complete record of merges (including, 
when less than 16000 items are 
included in the same merge, with what 
file the item was merged), and, by 
double clicking on any merge record 
folder  (in  the  ecco  Folder  pane),   you 
can instantly see all items which were 
included in that particular merge. 
 
If desired you can create a template 
with multiple "MM_Blank" Pop-Up 
List folders setup as sub folders of the 
MagicMerge Tracking folder. If any 
such folders are available, the merge 
log will be placed there, instead of the 
default 'new folders' location. The Pop-
Ups do not need any default values, 
and you can create multiple folder 
blanks easily by creating one, setting 
the properties to Pop-Up List, and then 
using control + C and control + V to 
copy and paste. Subsequent Control + 
Vs create multiple copies of the 
folder).  

The Word Template Building 
Tool:  

The tool is activated by right clicking 
on the MagicMerge tray icon and 
selecting the Template Builder (or by 
pressing Control + Winkey + W from 
within Ecco).  

Simply check the folders you desire to 
be included in the template building 
tool, and then click the 'Build' button. 
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tool, and then click the 'Build' button. 
 (You  can  instantly  update  the 
template after it has been built by 
simply clicking again on the "Build" 
button.)     Items  are  included  in  the 
selection pad in the order they were 
selected.   

Shift checking/unchecking any of 
the 'Parent" folders, will check or 
uncheck all of the children of that 
folder.  

For large folder lists, typing any letter 
will "jump" to the next folder starting 
with that letter, and you can use 
'Space" (or Shift+Space) to make 
selections and de-selections.  

Double clicking on "ItemText" will 
display and allow selection of the 
Ecco 'internal' folders.    

Note: the 'flex' virtual address folders 
Address_Line_1, Address_Line_2, City, 
State,  Zip_Code,  and  Country,   will  look 
first for an actual folder with that name, 
and if existing, will merge from those 
existing folder. Currently MagicMerge will 
use the 'Business' addresses as the folder 
values for the 'virtual' addresses.   Per item 
setting selection of Business vs. Home for 
the address folders is not currently 
supported.   By setting up a separate folder 
to designate which (Business or Home) 
should  be  an  item's  default  address,   you 
can have Word (using the "If" field) select 
the appropriate folders (eg. Home or 
Business) based on that folder's setting. For 
example:  

{ IF Default_address = "Home" 
    
{ MERGEFIELD Address_1_Home } 
    
{ MERGEFIELD Address_1_Business } 
} 
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Note: the first field (Folder) in the Word 
document containing the word "Email" 
or "E-mail"   will  be  used  to  determine 
which Folder contains the email address 
for "Email" Merges.  

You may close or shrink the folder 
selection window when you have 
selected the desired folders to include 
in the template tool.  

By double  clicking on any of the 
folders from the template tool, you 
can instantly insert a merge field for 
that folder into the currently active 
word  document.   (The  merge  field 
will be inserted at the current cursor 
location in Word.)  

(For long folder templates, Control + 
any key will 'jump' to the next item in 
the tool starting with that character.)  

 
 
NOTE:    

     1.Pressing  the "Control" 
key when selecting the "Template 
Builder",   allows  folders  selected  in 
the ecco folder tree to be added any 
currently listed folders on the tool.     

     2.Pressing  the 'Shift' key when 
selecting   "Template  Builder"  allows 
the   folder  tree  selection  to  be 
bypassed.   The  Template  Building 
Tool   will  be  built  based  on 
the already existing merge fields in 
the currently active Word 
document.  

In this alternate ('shift') mode, 
you can:  

1) Instantly create a template 
building tool using the already 
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building tool using the already 
existing  fields  in any word  file,  
and  

2) 'Load' the merge fields in one 
file,   and  then  open  another  file 
and insert the fields in 
the second file.  

 
Advanced Configuration Notes:  

An optional file, "MagicMergePIN.ini" can 
be placed in the MagicMerge directory, 
listing one-per-line standard files that will 
always be included in the MagicMerge file 
pulldown menu.   If those files are merged,  
they will also appear in use order in the 
'recent files' portion of the pulldown.  

Using the <Clear> option of the pulldown,  
the  recent  files  list  can  be  cleared.   The 
"PIN.ini" files can only be modified by 
modifying the ini file itself.  

Saved configuration options can be cleared 
by holding down the "Shift" key when you 
click   "OK"  on  the  MagicMerge  start-up 
dialog box. 

MagicMerge is designed to merge a wide 
range  ecco  file  structures.   In  order  to 
maximize  processing  speed,   aggregate 
blocks of merged data exceeding 
approximately 1/2  Meg  per  16  items  will 
be  ignored.   Single  items  (if  item  text  is 
merged), or an item's merged folder text 
can  each be  up  to  about  32,000  bytes  per 
item, so  long  as  such  items  are  not 
merged consequtively in  the merge.  Usual 
merge fields such as addresses, names, 
order  info,  etc.,   never  reach  1/2 
million characters of data per 16  items.   If 
your particular merge needs require special 
printing of dense  item  text or  folder data,  
you can order the industrial merge build 
which will do this.  That build is designed 
for millions of bytes in merge data in 
single merges and requires significantly 
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single merges and requires significantly 
more  memory  to  run.   Standard 
MagicMerge can still merge millions of 
bytes of item and folder data.  The merged 
data (from the ecco file) just cannot have a 
merge density of more than approximately 
1/2 million characters of merged ecco data 
per every 16 merged items.  

 
Advanced Ecco/Word usage 
Notes:  
 

The outline structure of Ecco is especially 
suited for printing reports built where: 
 

1. The first selected item is the TLI 
phonebook item containing folders 
relevant for name, company, address, 
etc. 
 
2. Subsequent selected items are the 
'transaction' level items desired in the 
report. 
 
 

To take advantage of this structure in Word, 
 you can use a special merge field to handle 
the  First  selected  item.   (eg.  to  include  a 
letter header, inside address, salutation, 
etc.).     This  can  be  built  with  folders 
relevant to the phonebook item, and totally 
different from the folders used in the 'report' 
section (transaction level items) in the 
document.   To  do  this  simply  use  "Report" 
style merge with the Word structure: 
 

{ IF { MergeSeq } = 1  
 
"Place the FIRST ITEM 
SELECTION HERE   (can be multi 
lines, include your folders to merge, 
etc.)" 
 
} { NEXTIF { MergeSeq } = 1}[or]  
    {  NEXTIF  {  MERGEFIELD 
Folder_in_report } = "" } 
 
Text (Folders to merge, etc.) for 
transactions goes here.... 
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transactions goes here.... 
 
{ IF { MergeRec } = { DocProperty 
EMRecordCount } "Put closing text 
here" } 

 
 

Note:   
1.  {  }   bracket  pairs  are  Word 
'Field'  indicators  and are created 
by  pressing  Control  +  F9   in 
Word. 

 
 

2. A special field, "{ DocProperty 
EMRecordCount }",   can be used 
to determine the number of 
records in a merge.  
 
[Note: This field also allows 
listing, for example, "Item 
{MergeRec} of { DocProperty 
EMRecordCount }", etc. ]  
 
 
3. To use extensive formatting 
and/or graphics as part of the 'first 
record only' section of a word 
document, an easy technique is to 
use the Word AutoText feature. 
Simply highlight the formatted 
text/graphics block you desire to 
use as  the  header,   and save as  a 
'AutoText'  block.   Then  in  the 
'first record only section' use 
"{ AUTOTEXT Text_Name *\ 
MERGEFORMAT}". (You can 
have multiple 'first record only' 
sections if needed)  

 
 
 
 
 
©Copr. 2006-2008 ISystems. All Rights 
Reserved.  
 
EUA, TERMS, ETC.: We are transmitting or delivering to you a copy of our 
software, similar to if we were transmitting or delivering to you a copy of a 
radio show. We own the original program, as an entire work, including but not 
limited to the coding, text, html, images, graphics, layout, design, and look and 
feel, all of which are COPYRIGHT by us, and all rights to which are retained 
by and RESERVED by us. Similarly, the source code including any and all 
parts which are based on our trade secret or any patented or patent-pending 
technology, are retained by us, and your right is limited to a right to use the 
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technology, are retained by us, and your right is limited to a right to use the 
object code distributed to you. You agree not to look under the hood, and to 
keep fully secret and confidential, even from your own eyes, all internal 
processes of the program.  
 
    We grant you, and only to you, the right to use, for either a single user on as 
many machines used exclusively by that user, or for a single machine with 
multiple non-remote users. You may, of course, make reasonable backups of 
the program, if kept securely by you, and not in such a way that others might 
have access or the opportunity to copy or steal the program from your backups.  
 
     You  are  authorized  to  re-transmit or copy the program for your own use, 
from a fixed media to another fixed media or to local RAM of your machine, 
in order to use the program in an ordinary fashion. You are not authorized to 
modify, crack, or hack the program. Application or implementation of any 
modification, crack, or hack, is a violation of this end user agreement, and a 
violation of the program's copyright.  
 
     The  the  full  extent  permitted  by  law,  no  warranties  are  made,  and  the 
software is transmitted "as-is". Use of this software has not been tested by us 
on your individual machine or circumstances, and you acknowledge this and 
you agree to assume all risk of use. No warranty of fitness for use, and no 
warranty for merchantability are made by us, and ALL IMPLIED 
WARRANTIES are, to the extent permitted by law, fully disclaimed by us. To 
the extent permitted by law, the limitations of remedies for any breach of 
warranty is limited to replacement of the software, or refund of the purchase 
price, at our exclusive option.  
 
 
    This product is distributed "AS-IS".  
 
 
     Please  share  any  comments,  suggestions,  or  problems  via: 
Feedback@eccoMAGIC.com  
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